PiDP-8/I SoftwareForum
Not logged in

os8-cp wth relative path support

(1) By tangent on 2019-02-04 19:18:39 [link]

I just tried using os8-cp for the first time and got yelled at:

  $ bin/os8-cp ./obj/cc8/os8/libc.sb  bin/v3d.rk05
  Abort: append_copy, out: Illegal OS/8 file spec containing a slash:DSK:./obj/cc8/os8/libc.sb

Yeah, I get that OS/8 doesn't support relative paths, but isn't what was meant pretty clear here?

I then tried this and got yelled at again:

  $ bin/os8-cp ./obj/cc8/os8/libc.sb  bin/v3d.rk05:libc.sb
  append_copy, into: Illegal OS/8 file spec containing a slash:bin/v3d.rk05:libc.sb

So...os8-cp currently requires both the source file and the disk image to be in the same directory?

(2) By poetnerd on 2019-02-04 22:57:15 in reply to 1

That's not how the arguments to os8-cp work. We specify the images to mount with a third argument rather than parsing the two file arguments to try and determine a system image.

To get what you want you need to say:

bin/os8-cp -rk0s bin/v3d.rk05 ./obj/cc8/os8/libc.sb DSK:

The "-rk0s" option means "Mount bin/v3d.rk05 on rk0 and use it as the system device."

If memory serves, we default to that so:

bin/os8-cp ./obj/cc8/os8/libc.sb DSK:

should work.